The main Pimero program and the Pimero Server are programs for Microsoft Windows.

Hardware-requirements:
  • 1 GHZ x86 compatible processor
  • 2 GB RAM
  • 250MB free Driverspace

requirements to the operating system:

  • Windows Vista
  • Windows 7
  • Windows 8
  • 32 und 64 bit Versions are supported

Pimero will automatically install all necessary components for you. This includes Microsoft .NET Framework 4.0 and Firebird SQL Server 2.1 if not already installed. Pimero will also work with newer versions of these components if they are already installed on your system. If any of these components could not be installed during Pimero Setup, please check if you already have the correct (or newer) version installed on your system.

Prerequisites for Synchronization with a Web Browser (Pimero Mobile)

If you want to work with your appointments in a web browser using Pimero Mobile, the installation of a Pimero server is required. For more details on server installation, click here or here for details on how to switch from an existing stand-alone installation to client-server mode. 

Browser requirements:

  • Mozilla Firefox
  • Google Chrome
  • Microsoft Internet Explorer 10
  • Opera

Possible installation problems

If Firebird SQL Server could not be installed automatically, please check first whether it is already installed on your system. To do this, open “Control Panel” -> “Programs and Features” and search the list for an entry similar to “Firebird 2.1”. Please check the version number. Version 2.1 or later should work fine with Pimero. If you have an older version, uninstall and install version 2.1 manually. You can download this version from https://www.firebirdsql.org .

Your Answer